Does YourSurveys not work anymore?


Quarter Crater
the past few days any time a survey is run through Your Survey it ends up to a blank page after i answer a couple of questions. i tried resetting my browser. nothing is working. anyone else having this issue?
What browser and version are you using?

If you try another browser, do you have any better results?

Can you try logging out of CashCrate and deleting all cookies and temporary Internet files? Then log back in. This should ensure that a fresh survey list loads for you.


Quarter Crater
it always worked fine up until like 2 days ago. I am using Safari on a Mac laptop. when i go to it from my Android phone it works no problem. I tried resetting my browser and deleting all the files and cookies and still having the same issue. Not sure why this is happening i never had a problem with the YourSurveys before on my laptop.
I searched our support database and found one other instance where things were coming up blank for a Safari user. In that case, the member tried another browser and that appeared to provide a resolution.

Also, if you have any popup or ad blockers turned on, turning them off may help as well.


Quarter Crater
on my laptop i only have safari. hope it works here again its really annoying doing it from the phone lol. another question. were dwell payments sent from last month yet? just making sure I'm not having the same issue as last time